Edit Menu (Editor)

See also Design Toolbar

Use Edit menu to duplicate, mirror, center, align, rotate, skew, join and split selected Objects. If you need to perform an operation only on one part of Object, you must split this Object into pieces first (see Split command below). After splitting, select the newly split part and perform the operation. Finally, you may join several Objects into one Object (see Join command below).

Most of these commands are also accessible via Design Toolbar and Working Area Popup Menu.

Edit Menu Commands:

Undo

Undo last operation. There are 20 levels of Undo available.

Redo

Redo previously undone operation.

Cut

Cut selected Objects and put them on Windows Clipboard.

Copy

Copy selected Objects to Windows Clipboard.

Paste

Paste Objects from Windows Clipboard.

Select All

Select all Objects.

Select Next

Select next Object.

Deselect All

Deselect all Objects.

Invert Selection

Invert current selection: Deselect selected Objects and select unselected Objects.

Delete

Delete selected Objects.

Duplicate

Duplicate selected Objects.

Auto Repeat

Repeat selected Objects along circle, line or rectangle.

Corner

Place selected Objects in each of the three other hoop corners. Place an Object in one of the hoop corners and then select this command to create a symmetrical design quickly and accurately.

Mirror

Mirror selected Objects horizontally or vertically.

Center

Center selected Objects on both axes or only on horizontal/vertical axis.

Align

Align selected Objects. This command will bring up a dialog box, in which align method can be chosen. Use this to line up selected components in relation to each other. Base for aligning is the first selected Object.

Rotate

Rotate selected Objects. This command will bring up a dialog box, in which desired angle of rotation can be specified.

Skew

Skew selected Objects horizontally or vertically. This command will bring up a dialog box, in which the desired angle can be specified.

Set Position

Set position of selected Objects. This command will bring up a dialog box, in which desired position can be specified.

Set Size

Set size of selected Objects. This command will bring up a dialog box, in which desired size can be specified. Embird can resize with density adjustment; choose this option in Options menu.

Set Density or Pattern

Set stitch density or fill pattern in selected Objects. This command will bring up a dialog box, in which the values of density for column and fill stitches can be specified. If you decide to change the pattern, you can choose the new one from the list of available patterns.

Set Envelope

Change envelope of selected Objects. For example you can change the envelope of lettering, which was not created in Embird.

Snap Objects to Guide Lines

Snap objects to guide lines when moving them along work area.

Lock Guide Lines

Lock guide lines to avoid their accidental misplacing.

Erase Guide Lines

Erase all guide lines.

Auto-Split

Split selected Objects automatically. This command will bring up a dialog box, in which the maximum width and height, maximum number of colors, and maximum number of stitches of each part can be chosen. It is possible to automatically split the design along the boundaries of multi-section hoops.

Separate

Separate parts in selected object.

Move

Use this command after selecting stitches in Freehand Select Mode, or after selecting stitches via Initial Stitch andEnding Stitch boxes in Select Mode. This menu will switch the mode to Points Editing Mode and automatically select points according to your stitch selection, so that you can move them across the Working Area.

Split

Split selected Object, cut out selected stitches. Two methods of splitting are possible: First Method: Select stitches to be cut out by freehand-defined polygon, often called Lasso. You must enter Freehand Select Mode if you want to split this way. After splitting, your selection becomes a new independent Object and is then treated like any other Object (save to disk, mirror, center, resize, skew etc.). Second Method: Specify initial and ending stitches of selection (for example, stitches 724 to 1242 cut out to create a new Object). This is enabled only if there is just one Object selected in Select Mode. Use Initial Stitch and Ending Stitch edit boxes (situated on Main Toolbar) to enter desired values. Object is split into parts, as follows: First part is composed of stitch 1 of the original design through the stitch preceding the Split's initial stitch. Therefore, in our example, the first part will contain stitches 1 to 723. Second part is composed of the Split's first stitch through the Split's last stitch. Therefore, in our example, the second part will contain stitches 724 through 1242. Third part, in this example, is composed of stitches 1243 through the original design's last stitch. All three parts after splitting become new independent Objects, displayed in the Objects Order Bar.

Join

Join selected Objects. Use this command to join selected Objects into one Object.

Slice

This command is similar to Split command, however, it will slice the design with smooth edges, not leaving small stitches as if you use the Split command. Select the stitches first using the Freehand Select Mode and then use this command to cut out selected stitches.

Mask

Use this command to mask two or more selected Objects. The stitches in the Object underneath will automatically be deleted where the upper Object overlaps.

Sort Colors

Sort colors in selected Objects. Use to join areas with the same colors and thus reduce the number of color changes; helpful when embroidering the same Object multiple times.

Smart Color Sort

Smart color sorting in selected Objects. Use to join areas with the same colors and thus reduce the number of color changes; while taking into account the layers of stitches to achieve the same visual appearance as in original Objects. Helpful when embroidering the same Object multiple times.

Reduce Colors

Use this command to reduce the number of colors in selected Objects.

Reverse Stitches

Use this command to reverse the order of stitches, so that the last stitch becomes first, the last-but-one becomes second, etc. Only the stitches of the same color are reversed, the order of colors remains the same.

Smart Reverse Stitches

Use this command to reverse the order of stitches in selected Objects while taking into account the layers of stitches to achieve the same visual appearance as in original Objects.

Stitch Type

Change the type of selected stitch, from floating to running stitch, for example. Select a single stitch using the Freehand Select Mode first. You also can select a single stitch by typing its number into both Initial Stitch and Ending Stitch boxes on the Main Toolbar at the top of the Editor screen.

Extend Floating Stitches

Extend floating (jump) stitches in selected Objects. Use this command to fix problem with some designs (typically in .PES or .PEC format), which causes that the jumps are untimely finished with non-zero-length running stitch.

Tidy Up Small Stitches

Use this command to delete small stitches in selected Objects.

Pull Compensation

Use this command to compensate the pull in selected Objects.

Edit Stitch File in Studio

Use this command to open selected Objects in Embird Studio. Find more about Studio software in its Help file - press F1 key when running this application. See also Studio Design command in Insert menu.

Edit Stitch File in Thred

Use this command to open selected Objects in Thred (version 1.029 or above). Thred is a versatile and affordable digitizing program, developed by Thredworks. It can be used with Embird, or as a stand alone application. More information, demo, registration and support for Thred are available at http://www.thredworks.com.